Count Updates are down
Incident Report for Hiver
Resolved
This incident has been resolved.
Posted Jun 22, 2022 - 06:54 UTC
Identified
We are facing capacity issues with email counts. We are trying to come up with a fix and our engineering team will come back with an update in the next 24 hours. Users might see a delay in email counts getting updated in the meantime.
Posted Jun 21, 2022 - 19:07 UTC
Investigating
We are facing delays with email counts being updated in Shared Mailbox. Our Engineering team is working on it and we will update shortly.
Posted Jun 21, 2022 - 17:53 UTC
This incident affected: Hiver (Notification Services).