Hiver services are experiencing a downtime
Incident Report for Hiver
Resolved
We're back! All our Hiver services are up and running now. We thank you for your patience.
Posted Jul 16, 2024 - 03:58 PDT
Identified
We are experiencing issues with the Hiver extension. Our best engineers are continuing to diagnose the issue. We will share the next update within 30 minutes.
Posted Jul 16, 2024 - 03:32 PDT
This incident affected: Web App (Email User Experience, Email Sync) and Notification Services, Analytics, Hiver Automation, Hiver's Views.