Email sync service is partially down.
Incident Report for Hiver
Resolved
This incident has been resolved
Posted Jun 21, 2022 - 17:14 PDT
Monitoring
A fix has been implemented and we are monitoring the results
Posted Jun 21, 2022 - 17:12 PDT
Investigating
We have noticed email sync delay for some users.
We are currently investigating the issue.
Posted Jun 21, 2022 - 15:09 PDT
This incident affected: Web App (Email Sync).