The AWS service disruption has been resolved, and Hiver services have fully recovered.
Thank you for your patience and understanding.
Posted Jul 24, 2026 - 06:16 PDT
Update
We are seeing initial signs of recovery as AWS services begin to stabilize. Hiver services are also gradually recovering.
Our team continues to closely monitor the situation and will provide further updates as we work toward full service restoration.
Posted Jul 24, 2026 - 05:11 PDT
Monitoring
We are currently experiencing a service disruption affecting Hiver due to an ongoing outage with Amazon Web Services (AWS), one of our infrastructure providers.
As a result, some users may experience issues with Hiver services. Our team is actively monitoring the situation and working to minimize the impact.
We will provide further updates as more information becomes available.
Posted Jul 24, 2026 - 05:01 PDT
This incident affected: Hiver Omni (Email User Experience, Email sync), Hiver in Gmail (Email User Experience, Email Sync), and Infrastructure (AWS route53-us-west-2, AWS apigateway-us-west-2).