Hiver services are currently experiencing a degradation in performance

Incident Report for Hiver

Resolved

We're back! All our Hiver services are up and running now. We thank you for your patience.
Posted Nov 16, 2023 - 11:50 PST

Identified

Hiver services are currently experiencing performance degradation. Few users have reported a delay in email sync, and Hiver's activity panel feature is not loading as expected. Our best engineers are actively diagnosing the issue. We will provide the next update shortly.
Posted Nov 16, 2023 - 11:15 PST
This incident affected: Web App (Email User Experience, Email Sync).