Hiver is facing a compatibility issue with the latest Chrome version 115.
Incident Report for Hiver
Resolved
We're back! All our Hiver services are up and running now. We thank you for your patience.
Posted Jul 25, 2023 - 08:11 PDT
Monitoring
We have successfully applied a fix for the bulk assignment of emails. We are closely monitoring our system.
Posted Jul 25, 2023 - 05:15 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 25, 2023 - 03:50 PDT
Update
A fix for the email template issue has been rolled out. However, our team is still investigating the root cause of the problem with the bulk assignment of emails. We will keep you informed as we make progress in resolving this matter.
Posted Jul 25, 2023 - 03:46 PDT
Identified
Hiver's email templates and bulk action features are presently inaccessible. Rest assured, our engineering team is diligently working to resolve this issue promptly.
Posted Jul 24, 2023 - 21:23 PDT
Update
The fix has been deployed, and we are actively monitoring the system. Our primary focus is to restore full functionality, allowing you to use Hiver without any interruptions. As soon as the next update is ready, we will share it with you promptly.
Posted Jul 24, 2023 - 13:57 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 24, 2023 - 12:57 PDT
Identified
An important update regarding the latest Chrome version, Chrome 115 (released on July 22nd). Some customers have reported difficulties accessing and using Hiver after upgrading to this version.

Our engineers are actively working on resolving the compatibility issue. In the meantime, we advise you not to upgrade to Chrome 115 this week. We will provide further updates on the solutions and next steps as they become available.
Posted Jul 24, 2023 - 05:56 PDT
This incident affected: Web App (Email User Experience).