Hiver app degraded performance
Incident Report for Hiver
Resolved
The issue has been resolved. If you are still facing issues with Hiver not loading in Gmail, refresh your Gmail
Posted Feb 26, 2020 - 14:32 PST
Investigating
We are facing issues with Hiver not loading for a few of our user since last 1 hour. We are looking into it
Posted Feb 26, 2020 - 14:10 PST
This incident affected: Web App (Email User Experience).