Hiver's email synchronisation is currently experiencing a delay.
Incident Report for Hiver
Resolved
We have deployed a fix for the email synchronisation delay. All Hiver services have been reinstated and are running seamlessly. We would like to express our sincere appreciation for your patience and understanding during this period.
Posted Aug 14, 2023 - 07:55 PDT
Identified
We are experiencing issues with email synchronisation. Our best engineers are continuing to diagnose the issue. We will share the next update within 30 minutes
Posted Aug 14, 2023 - 07:13 PDT
This incident affected: Web App (Email Sync).