Hiver is experiencing issues with the web app
Incident Report for Hiver
Resolved
This incident has been resolved.
Posted Jun 22, 2022 - 12:59 PDT
Investigating
Hiver extension might not function inside Gmail currently. We are looking into the issue and would provide updates soon.
Posted Jun 22, 2022 - 07:28 PDT
This incident affected: Web App (Email User Experience).