Sync delay
Incident Report for Hiver
Resolved
This incident has been resolved.
Posted Oct 08, 2020 - 15:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 08, 2020 - 15:11 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 08, 2020 - 14:53 UTC
Investigating
Hiver is experiencing delay in email sync.

We are looking into the issue and would provide updates shortly.
Posted Oct 08, 2020 - 14:11 UTC
This incident affected: Hiver (Email Sync).