Hiver services are experiencing a downtime

Incident Report for Hiver

Resolved

All Hiver services are now fully operational. We thank you for your patience and understanding.
Posted Mar 25, 2025 - 02:53 PDT

Update

We are actively deploying a fix for the issue with the Hiver extension. Our engineering team is working to resolve this as quickly as possible. We appreciate your patience.
Posted Mar 25, 2025 - 02:52 PDT

Identified

We are currently investigating issues with the Hiver extension. Our engineering team is actively working to identify the root cause. The next update will be provided within 30 minutes.
Posted Mar 25, 2025 - 02:35 PDT
This incident affected: Web App (Email User Experience, Email Sync).