Hiver Services Down
Incident Report for Hiver
Resolved
This incident has been resolved.
Posted Aug 31, 2021 - 23:00 UTC
Identified
We are currently having Internet Connectivity issues at our Cloud Provider(AWS).
Posted Aug 31, 2021 - 19:02 UTC
This incident affected: Hiver (Web App, Email Sync, Notification Services, Analytics).