Count Updates are down
Incident Report for Hiver
Resolved
This incident has been resolved.
Posted Jun 22, 2022 - 19:59 UTC
Investigating
We are facing delays with email counts being updated in Shared Mailbox. Our Engineering team is working on it and we will update shortly.
Posted Jun 22, 2022 - 08:13 UTC
This incident affected: Hiver (Notification Services).