Hiver's Activity Panel services are currently experiencing performance degradation
Incident Report for Hiver
Resolved
We're back! Hiver activity panel services are up and running now. We thank you for your patience.
Posted Jul 21, 2023 - 14:08 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 21, 2023 - 12:18 PDT
Investigating
We are experiencing issues with Hiver's Activity Panel. Our best engineers are continuing to diagnose the issue. We will share the next update within 30 minutes.
Posted Jul 21, 2023 - 12:09 PDT
This incident affected: Web App (Email User Experience).