Delay in email sync
Incident Report for Hiver
Resolved
This incident has been resolved.
Posted Mar 08, 2021 - 18:49 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 08, 2021 - 18:20 UTC
Investigating
Hiver is experiencing delay in email sync.
We are looking into the issue and would provide updates shortly.
Posted Mar 08, 2021 - 17:20 UTC
This incident affected: Hiver (Email Sync).