Hiver's Activity Panel service is currently experiencing degraded performance
Incident Report for Hiver
Resolved
Our Engineers have successfully implemented the fix for Hiver's activity panel issue. All Hiver services have been restored to full functionality. We appreciate your continued patience.
Posted Nov 16, 2023 - 06:29 PST
Update
We appreciate your continued patience as we delve into the ongoing challenges affecting access to Hiver's activity panel. Our dedicated engineering team is actively engaged in a thorough investigation to pinpoint the root cause.

Rest assured, our team is working diligently to gather the necessary details for a comprehensive update. Your understanding is invaluable to us, and we are committed to resolving this matter promptly.
Posted Nov 14, 2023 - 11:21 PST
Investigating
Some users are currently experiencing difficulty accessing Hiver's activity panel. Our dedicated engineers are actively investigating the root cause of this issue. Rest assured, we are prioritizing this matter and will provide you with a comprehensive update soon. Thank you for your patience and understanding.
Posted Nov 14, 2023 - 08:55 PST
This incident affected: Web App (Email User Experience).